// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\w.{1,25})\s").unwrap();
let string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vestibulum semper nisi id laoreet blandit. Nulla sit amet nisl non purus egestas ornare. Nullam pretium est sed ultrices imperdiet.
Phasellus dignissim tempus pretium. Praesent odio arcu, mollis non tincidunt eget, varius id ipsum. Nullam erat felis, varius non bibendum non, ullamcorper sit amet urna. ";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}