#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([-\+]?\d+,[-\+]?\d+)"
Local $sString = "@@ -74,6 +73,7 @@ " & @CRLF & _
" <dependency> <groupId>com.jolbox</groupId> " & @CRLF & _
" <artifactId>bonecp-test" & @CRLF & _
" - commons</artifactId> " & @CRLF & _
" + <classifier>${project.classifier}</classifier> " & @CRLF & _
" <scope>test</scope>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")