import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([-\\+]?\\d+,[-\\+]?\\d+)";
final String string = "@@ -74,6 +73,7 @@ \n"
+ " <dependency> <groupId>com.jolbox</groupId> \n"
+ " <artifactId>bonecp-test\n"
+ " - commons</artifactId> \n"
+ " + <classifier>${project.classifier}</classifier> \n"
+ " <scope>test</scope>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}