using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([-\+]?\d+,[-\+]?\d+)";
string input = @"@@ -74,6 +73,7 @@
<dependency> <groupId>com.jolbox</groupId>
<artifactId>bonecp-test
- commons</artifactId>
+ <classifier>${project.classifier}</classifier>
<scope>test</scope>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}