using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""name\"":[^}]*";
string input = @"{
""caution"": ""Filer is in maintenance mode, API might not work as normal."",
""reslt"": {
""AS-Audit license status"": "",
""rabbitMQInfo"": {
""name"": ""RMQDestination_3"",
""hostname"": ""10.32.12.114"",
""port"": ""5672"",
""RMQuser"": ""PanzuraOwner"",
""RMQpassword"": ""PanzuraOwner"",
""vhost"": ""panzura"",
""exchange"": ""panzura.incoming.ex"",
""headers"": ""filer_id=3"",
""enable_ssl"": ""0""
}
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}