import Foundation
let pattern = #"\"name\":[^}]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"caution": "Filer is in maintenance mode, API might not work as normal.",
"reslt": {
"AS-Audit license status": "",
"rabbitMQInfo": {
"name": "RMQDestination_3",
"hostname": "10.32.12.114",
"port": "5672",
"RMQuser": "PanzuraOwner",
"RMQpassword": "PanzuraOwner",
"vhost": "panzura",
"exchange": "panzura.incoming.ex",
"headers": "filer_id=3",
"enable_ssl": "0"
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)