use strict;
my $str = '{
"caution": "Filer is in maintenance mode, API might not work as normal.",
"reslt": {
"AS-Audit license status": "",
"rabbitMQInfo": {
"name": "RMQDestination_3",
"hostname": "10.32.12.114",
"port": "5672",
"RMQuser": "PanzuraOwner",
"RMQpassword": "PanzuraOwner",
"vhost": "panzura",
"exchange": "panzura.incoming.ex",
"headers": "filer_id=3",
"enable_ssl": "0"
}
}
}';
my $regex = qr/\"name\":[^}]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}