import re
regex = re.compile(r"\"name\":[^}]*", flags=re.MULTILINE)
test_str = ("{\n"
" \"caution\": \"Filer is in maintenance mode, API might not work as normal.\",\n"
" \"reslt\": {\n"
" \"AS-Audit license status\": \"\",\n"
" \"rabbitMQInfo\": {\n"
" \"name\": \"RMQDestination_3\",\n"
" \"hostname\": \"10.32.12.114\",\n"
" \"port\": \"5672\",\n"
" \"RMQuser\": \"PanzuraOwner\",\n"
" \"RMQpassword\": \"PanzuraOwner\",\n"
" \"vhost\": \"panzura\",\n"
" \"exchange\": \"panzura.incoming.ex\",\n"
" \"headers\": \"filer_id=3\",\n"
" \"enable_ssl\": \"0\"\n"
" }\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")