import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"name\\\":[^\\}]*";
final String string = "{\n"
+ " \"caution\": \"Filer is in maintenance mode, API might not work as normal.\",\n"
+ " \"reslt\": {\n"
+ " \"AS-Audit license status\": \"\",\n"
+ " \"rabbitMQInfo\": {\n"
+ " \"name\": \"RMQDestination_3\",\n"
+ " \"hostname\": \"10.32.12.114\",\n"
+ " \"port\": \"5672\",\n"
+ " \"RMQuser\": \"PanzuraOwner\",\n"
+ " \"RMQpassword\": \"PanzuraOwner\",\n"
+ " \"vhost\": \"panzura\",\n"
+ " \"exchange\": \"panzura.incoming.ex\",\n"
+ " \"headers\": \"filer_id=3\",\n"
+ " \"enable_ssl\": \"0\"\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}