const regex = /^(\d+\.?\d*[fF]|\d+\.?(?![\p{L}_])\d*[fF]?|\d*\.\d+[fF]?)/uimg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+\\.?\\d*[fF]|\\d+\\.?(?![\\p{L}_])\\d*[fF]?|\\d*\\.\\d+[fF]?)', 'uimg')
const str = `10
50.0
42.ToString()
0.1.GetType()
9..GetHashCode()
45.1 // float
10f // float
0. // float
1 // int`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}