import re
regex = re.compile(r"^(\d+\.?\d*[fF]|\d+\.?(?![\p{L}_])\d*[fF]?|\d*\.\d+[fF]?)", flags=re.UNICODE | re.IGNORECASE | re.MULTILINE)
test_str = ("10\n"
"50.0\n\n"
"42.ToString()\n"
"0.1.GetType()\n"
"9..GetHashCode()\n\n"
"45.1 // float\n"
"10f // float\n"
"0. // float\n"
"1 // int")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")