re = /^(\d+\.?\d*[fF]|\d+\.?(?![\p{L}_])\d*[fF]?|\d*\.\d+[fF]?)/im
str = '10
50.0
42.ToString()
0.1.GetType()
9..GetHashCode()
45.1 // float
10f // float
0. // float
1 // int'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end