$re = '/^(\d+\.?\d*[fF]|\d+\.?(?![\p{L}_])\d*[fF]?|\d*\.\d+[fF]?)/uim';
$str = '10
50.0
42.ToString()
0.1.GetType()
9..GetHashCode()
45.1 // float
10f // float
0. // float
1 // int';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);