#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\blong\b|\banyword\b)(-| )(\blong\b|\banyword\b)"
Local $sString = "Sample text:" & @CRLF & _
"test text long long test text" & @CRLF & _
"test text long long long long long long test text" & @CRLF & _
"test text long long test test long long long test text" & @CRLF & _
"" & @CRLF & _
"How it should be:" & @CRLF & _
"test text long-long test text" & @CRLF & _
"test text long-long-long-long-long-long test text" & @CRLF & _
"test text long-long test test long-long-long test text" & @CRLF & _
"" & @CRLF & _
"How does it work now:" & @CRLF & _
"test text long-long test text" & @CRLF & _
"test text long-long long-long long-long test text" & @CRLF & _
"test text long-long test test long-long long test text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")