import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\blong\\b|\\banyword\\b)(-| )(\\blong\\b|\\banyword\\b)";
final String string = "Sample text:\n"
+ "test text long long test text\n"
+ "test text long long long long long long test text\n"
+ "test text long long test test long long long test text\n\n"
+ "How it should be:\n"
+ "test text long-long test text\n"
+ "test text long-long-long-long-long-long test text\n"
+ "test text long-long test test long-long-long test text\n\n"
+ "How does it work now:\n"
+ "test text long-long test text\n"
+ "test text long-long long-long long-long test text\n"
+ "test text long-long test test long-long long test text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}