package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\blong\b|\banyword\b)(-| )(\blong\b|\banyword\b)`)
var str = `Sample text:
test text long long test text
test text long long long long long long test text
test text long long test test long long long test text
How it should be:
test text long-long test text
test text long-long-long-long-long-long test text
test text long-long test test long-long-long test text
How does it work now:
test text long-long test text
test text long-long long-long long-long test text
test text long-long test test long-long long test text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}