re = /(\blong\b|\banyword\b)(-| )(\blong\b|\banyword\b)/m
str = 'Sample text:
test text long long test text
test text long long long long long long test text
test text long long test test long long long test text
How it should be:
test text long-long test text
test text long-long-long-long-long-long test text
test text long-long test test long-long-long test text
How does it work now:
test text long-long test text
test text long-long long-long long-long test text
test text long-long test test long-long long test text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end