using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^41:01:00\d{5}:\d{1,4}$";
string input = @"Совпадает
41:01:0010126:2614
41:01:0010114:51
41:01:0010113:291
41:01:0010112:19
Не совпадает
41:01:00101 26:2614
41:01:001114:51
41:01:1010113:291
41:01:001011219";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}