import re
regex = re.compile(r"^41:01:00\d{5}:\d{1,4}$", flags=re.MULTILINE)
test_str = ("Совпадает\n"
"41:01:0010126:2614\n"
"41:01:0010114:51\n"
"41:01:0010113:291\n"
"41:01:0010112:19\n"
"Не совпадает\n"
"41:01:00101 26:2614\n"
"41:01:001114:51\n"
"41:01:1010113:291\n"
"41:01:001011219")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")