import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^41:01:00\\d{5}:\\d{1,4}$";
final String string = "Совпадает\n"
+ "41:01:0010126:2614\n"
+ "41:01:0010114:51\n"
+ "41:01:0010113:291\n"
+ "41:01:0010112:19\n"
+ "Не совпадает\n"
+ "41:01:00101 26:2614\n"
+ "41:01:001114:51\n"
+ "41:01:1010113:291\n"
+ "41:01:001011219";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}