$re = '/^41:01:00\d{5}:\d{1,4}$/m';
$str = 'Совпадает
41:01:0010126:2614
41:01:0010114:51
41:01:0010113:291
41:01:0010112:19
Не совпадает
41:01:00101 26:2614
41:01:001114:51
41:01:1010113:291
41:01:001011219';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);