const regex = new RegExp('(?P<command>\\w{1,})(\\s?-\\s?(?P<description>.*))?', 'gm')
const str = `avvisi
calcola - Evaluate one or more algebric expressions
caratteri - Count the characters in a text message (use it in reply)
ciclopi - CiloPi stations status
coop - Get UniCoop Firenze opening hours for Pisa Cisanello shop
doodle - Manage doodle-type surveys
help - Help
language - Change language settings
monitor - Monitor a web page and notify changes
note - Save up to 10 notes, callable via inline query
ping - Check if bot is online
quando - Get the original sending datetime for a message (use it in reply)
reminder - Set a reminder
suggestion - Send a suggestion to help improve the bot
tastiera - Send a keyboard with bot commands
ciaone
ciaone - fdfdf
della - f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}