use strict;
my $str = 'avvisi
calcola - Evaluate one or more algebric expressions
caratteri - Count the characters in a text message (use it in reply)
ciclopi - CiloPi stations status
coop - Get UniCoop Firenze opening hours for Pisa Cisanello shop
doodle - Manage doodle-type surveys
help - Help
language - Change language settings
monitor - Monitor a web page and notify changes
note - Save up to 10 notes, callable via inline query
ping - Check if bot is online
quando - Get the original sending datetime for a message (use it in reply)
reminder - Set a reminder
suggestion - Send a suggestion to help improve the bot
tastiera - Send a keyboard with bot commands
ciaone
ciaone - fdfdf
della - f';
my $regex = qr/(?P<command>\w{1,})(\s?-\s?(?P<description>.*))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}