// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<command>\w{1,})(\s?-\s?(?P<description>.*))?").unwrap();
let string = "avvisi
calcola - Evaluate one or more algebric expressions
caratteri - Count the characters in a text message (use it in reply)
ciclopi - CiloPi stations status
coop - Get UniCoop Firenze opening hours for Pisa Cisanello shop
doodle - Manage doodle-type surveys
help - Help
language - Change language settings
monitor - Monitor a web page and notify changes
note - Save up to 10 notes, callable via inline query
ping - Check if bot is online
quando - Get the original sending datetime for a message (use it in reply)
reminder - Set a reminder
suggestion - Send a suggestion to help improve the bot
tastiera - Send a keyboard with bot commands
ciaone
ciaone - fdfdf
della - f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}