import Foundation
let pattern = #"(?P<command>\w{1,})(\s?-\s?(?P<description>.*))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
avvisi
calcola - Evaluate one or more algebric expressions
caratteri - Count the characters in a text message (use it in reply)
ciclopi - CiloPi stations status
coop - Get UniCoop Firenze opening hours for Pisa Cisanello shop
doodle - Manage doodle-type surveys
help - Help
language - Change language settings
monitor - Monitor a web page and notify changes
note - Save up to 10 notes, callable via inline query
ping - Check if bot is online
quando - Get the original sending datetime for a message (use it in reply)
reminder - Set a reminder
suggestion - Send a suggestion to help improve the bot
tastiera - Send a keyboard with bot commands
ciaone
ciaone - fdfdf
della - f
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)