using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Connector: ([0-9]*) .* E_DE_HH: ([0-9]*) .*";
string substitution = @"\1 \2";
string input = @"[10:26:33]: Connector: 8965 Info1: 8 Info2: 8 Info3: 4 E_DE_HH: 6000 Info4: 99
[10:26:33]: Connector: 8963 Info2: 8 Info2: 8 Info3: 4 E_DE_HH: 6001 Info4: 99";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}