// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Connector: ([0-9]*) .* E_DE_HH: ([0-9]*) .*").unwrap();
let string = "[10:26:33]: Connector: 8965 Info1: 8 Info2: 8 Info3: 4 E_DE_HH: 6000 Info4: 99
[10:26:33]: Connector: 8963 Info2: 8 Info2: 8 Info3: 4 E_DE_HH: 6001 Info4: 99";
let substitution = "\\1 \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}