const regex = /Connector: ([0-9]*) .* E_DE_HH: ([0-9]*) .*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Connector: ([0-9]*) .* E_DE_HH: ([0-9]*) .*', 'gm')
const str = `[10:26:33]: Connector: 8965 Info1: 8 Info2: 8 Info3: 4 E_DE_HH: 6000 Info4: 99
[10:26:33]: Connector: 8963 Info2: 8 Info2: 8 Info3: 4 E_DE_HH: 6001 Info4: 99`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);