import re
regex = re.compile(r"Connector: ([0-9]*) .* E_DE_HH: ([0-9]*) .*", flags=re.MULTILINE)
test_str = ("[10:26:33]: Connector: 8965 Info1: 8 Info2: 8 Info3: 4 E_DE_HH: 6000 Info4: 99\n"
"[10:26:33]: Connector: 8963 Info2: 8 Info2: 8 Info3: 4 E_DE_HH: 6001 Info4: 99")
subst = "\\1 \\2"
result = regex.sub(subst, test_str)
if result:
print(result)