import Foundation
let pattern = #"Connector: ([0-9]*) .* E_DE_HH: ([0-9]*) .*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[10:26:33]: Connector: 8965 Info1: 8 Info2: 8 Info3: 4 E_DE_HH: 6000 Info4: 99
[10:26:33]: Connector: 8963 Info2: 8 Info2: 8 Info3: 4 E_DE_HH: 6001 Info4: 99
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)