#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w{4,})(?!\w|\*|[^"]*"(?:(?:[^"]*"{2}))*[^"]*$)"
Local $sString = "Cats in some stylish* hats" & @CRLF & _
"Cats in "some very* stylish" hats" & @CRLF & _
""
Local $sSubst = "$1*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)