$re = '/(\w{4,})(?!\w|\*|[^"]*"(?:(?:[^"]*"{2}))*[^"]*$)/m';
$str = 'Cats in some stylish* hats
Cats in "some very* stylish" hats
';
$subst = "$1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;