using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{4,})(?!\w|\*|[^""]*""(?:(?:[^""]*""{2}))*[^""]*$)";
string substitution = @"$1*";
string input = @"Cats in some stylish* hats
Cats in ""some very* stylish"" hats
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}