import Foundation
let pattern = #"(\w{4,})(?!\w|\*|[^"]*"(?:(?:[^"]*"{2}))*[^"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Cats in some stylish* hats
Cats in "some very* stylish" hats
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)