re = /(\w{4,})(?!\w|\*|[^"]*"(?:(?:[^"]*"{2}))*[^"]*$)/m
str = 'Cats in some stylish* hats
Cats in "some very* stylish" hats
'
subst = '$1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result