using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+?(\d{1,2}|1\-\d{1,3}|0)+(3[2-9]|5[6|8|9]|9[]|8[1-9]|7[0|6-9])+([0-9]{7})";
string input = @"0342138303
+84342138303";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}