const regex = /\+?(\d{1,2}|1\-\d{1,3}|0)+(3[2-9]|5[6|8|9]|9[]|8[1-9]|7[0|6-9])+([0-9]{7})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+?(\\d{1,2}|1\\-\\d{1,3}|0)+(3[2-9]|5[6|8|9]|9[]|8[1-9]|7[0|6-9])+([0-9]{7})', 'gm')
const str = `0342138303
+84342138303`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}