package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+?(\d{1,2}|1\-\d{1,3}|0)+(3[2-9]|5[6|8|9]|9[]|8[1-9]|7[0|6-9])+([0-9]{7})`)
var str = `0342138303
+84342138303`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}