// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\+?(\d{1,2}|1\-\d{1,3}|0)+(3[2-9]|5[6|8|9]|9[]|8[1-9]|7[0|6-9])+([0-9]{7})").unwrap();
let string = "0342138303
+84342138303";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}