re = /\+?(\d{1,2}|1\-\d{1,3}|0)+(3[2-9]|5[6|8|9]|9[]|8[1-9]|7[0|6-9])+([0-9]{7})/m
str = '0342138303
+84342138303'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end