using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\.)?((?<=\.?)\/src)|(src\/)";
string substitution = @"";
string input = @"src/abc
src/abc/bxc
bxc/src/abc
/src/src/abc
/src/abc
npx src/icons
node /src/icons
node bxc/src/icons
node /bxc/src/icons
node /bxc/icons
node /src/plugins
/src
src
src/
./src
""build:icons"": ""tsx /src/plugins/iconify/build-icons.ts"",
""build:icons"": ""tsx src/plugins/iconify/build-icons.ts"",
'@axios': fileURLToPath(new URL('./src/plugins/axios', import.meta.url)),";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}