# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\.)?((?<=\.?)\/src)|(src\/)"
test_str = ("src/abc\n"
"src/abc/bxc\n"
"bxc/src/abc\n"
"/src/src/abc\n"
"/src/abc\n"
"npx src/icons\n"
"node /src/icons\n"
"node bxc/src/icons\n"
"node /bxc/src/icons\n"
"node /bxc/icons\n"
"node /src/plugins\n"
"/src\n"
"src\n"
"src/\n"
"./src\n\n"
"\"build:icons\": \"tsx /src/plugins/iconify/build-icons.ts\",\n"
"\"build:icons\": \"tsx src/plugins/iconify/build-icons.ts\",\n"
"'@axios': fileURLToPath(new URL('./src/plugins/axios', import.meta.url)),")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.