import Foundation
let pattern = #"(^\.)?((?<=\.?)\/src)|(src\/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
src/abc
src/abc/bxc
bxc/src/abc
/src/src/abc
/src/abc
npx src/icons
node /src/icons
node bxc/src/icons
node /bxc/src/icons
node /bxc/icons
node /src/plugins
/src
src
src/
./src
"build:icons": "tsx /src/plugins/iconify/build-icons.ts",
"build:icons": "tsx src/plugins/iconify/build-icons.ts",
'@axios': fileURLToPath(new URL('./src/plugins/axios', import.meta.url)),
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)