use strict;
my $str = 'src/abc
src/abc/bxc
bxc/src/abc
/src/src/abc
/src/abc
npx src/icons
node /src/icons
node bxc/src/icons
node /bxc/src/icons
node /bxc/icons
node /src/plugins
/src
src
src/
./src
"build:icons": "tsx /src/plugins/iconify/build-icons.ts",
"build:icons": "tsx src/plugins/iconify/build-icons.ts",
\'@axios\': fileURLToPath(new URL(\'./src/plugins/axios\', import.meta.url)),';
my $regex = qr/(^\.)?((?<=\.?)\/src)|(src\/)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";