const regex = /^(?=^[^\d]*\d[^\d]*\d[^\d]*$)(?=.*[a-z])(?=.*[A-Z]).{8,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=^[^\\d]*\\d[^\\d]*\\d[^\\d]*$)(?=.*[a-z])(?=.*[A-Z]).{8,}$', 'gm')
const str = `123456789
abcdefghi
ABCDEFGHI
abcdABC12
abcdABC121
.12nabdh#A
Abc4k9h2L
Abc4k9hL+
Abc4l@s\$kl4 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}