#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Ламінат (.+ \d+(?:\/\d+)?) ([^\(]+)"
Local $sString = "3924 Ламінат Parfe Floor 7/32 Дуб Мірандо (2,663)/10шт" & @CRLF & _
"2596 Ламінат Kappa 8 Дуб Ахілл (2,397 м2)/9шт" & @CRLF & _
"2593 Ламінат Excellence 8 Дуб Бельфаст (2,397)/9шт" & @CRLF & _
"3504 Ламінат Excellence 8 Дуб Романський (2,397)/9шт" & @CRLF & _
"3280 Ламінат Marine 10/32 Дуб Тихий фаска (1,535м2)/7 шт"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")