package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Ламінат (.+ \d+(?:\/\d+)?) ([^\(]+)`)
var str = `3924 Ламінат Parfe Floor 7/32 Дуб Мірандо (2,663)/10шт
2596 Ламінат Kappa 8 Дуб Ахілл (2,397 м2)/9шт
2593 Ламінат Excellence 8 Дуб Бельфаст (2,397)/9шт
3504 Ламінат Excellence 8 Дуб Романський (2,397)/9шт
3280 Ламінат Marine 10/32 Дуб Тихий фаска (1,535м2)/7 шт`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}