use strict;
my $str = '3924 Ламінат Parfe Floor 7/32 Дуб Мірандо (2,663)/10шт
2596 Ламінат Kappa 8 Дуб Ахілл (2,397 м2)/9шт
2593 Ламінат Excellence 8 Дуб Бельфаст (2,397)/9шт
3504 Ламінат Excellence 8 Дуб Романський (2,397)/9шт
3280 Ламінат Marine 10/32 Дуб Тихий фаска (1,535м2)/7 шт';
my $regex = qr/Ламінат (.+ \d+(?:\/\d+)?) ([^\(]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}