import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Ламінат (.+ \\d+(?:\\/\\d+)?) ([^\\(]+)";
final String string = "3924 Ламінат Parfe Floor 7/32 Дуб Мірандо (2,663)/10шт\n"
+ "2596 Ламінат Kappa 8 Дуб Ахілл (2,397 м2)/9шт\n"
+ "2593 Ламінат Excellence 8 Дуб Бельфаст (2,397)/9шт\n"
+ "3504 Ламінат Excellence 8 Дуб Романський (2,397)/9шт\n"
+ "3280 Ламінат Marine 10/32 Дуб Тихий фаска (1,535м2)/7 шт";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}