import Foundation
let pattern = #"Ламінат (.+ \d+(?:\/\d+)?) ([^\(]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3924 Ламінат Parfe Floor 7/32 Дуб Мірандо (2,663)/10шт
2596 Ламінат Kappa 8 Дуб Ахілл (2,397 м2)/9шт
2593 Ламінат Excellence 8 Дуб Бельфаст (2,397)/9шт
3504 Ламінат Excellence 8 Дуб Романський (2,397)/9шт
3280 Ламінат Marine 10/32 Дуб Тихий фаска (1,535м2)/7 шт
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)